Top / Software / 2ch-Browser

2 ちゃんねるブラウザの FAQ

2ch 新仕様に対応した 2ch ブラウザありますか?

恐らくありません。 が、ローカルプロキシを利用すれば、未対応の 2ch ブラウザをそのまま使えるそうですよ。

w3m-2ch

w3m-2ch をインストールしたい

実行に必要なパッケージをインストール

# aptitude install w3m wget

w3m の cgi-bin ディレクトリを指定

$ echo "sedcgi_bin $HOME/cgi-bin" >> ~/.w3m/config

http://www.geocities.jp/smug5680/ からアーカイブをダウンロード

アーカイブを展開してインストール

$ tar xf  w3m-2ch-XXX.tar.gz
$ cd w3m-2ch-XXX ; ./install.sh

w3m-2ch を起動

$ w3m -o cgi_bin=$HOME/cgi-bin 'file:/cgi-bin/w3m-2ch.cgi?PrintBoardList'

文字化けする

文書の標準の文字コードを Japanese (Shift_JIS, CP932) にすれば回避できます。

$ echo "document_charset Shift_JIS" >> ~/.w3m/config


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2006-12-26 (火) 19:57:50 (3987d)